Auteur Sujet: terminal évolué (sakura, rox-term ou autre)  (Lu 465 fois)

oui

  • Jr. Member
  • **
  • Messages: 81
  • Karma: -1
terminal évolué (sakura, rox-term ou autre)
« le: dim. avril 10 14:30:17 2016 »
bonjour

comme à mon habitude, c'est vers le weekend que je tente la construction.
j'ai eu une déconvenue qui tient à mon ordi, pas à NuTyx:
la touche droite du PAD ne répond plus.
donc le copier-coller de Linux ne fonctionne plus car il faut presser simultanément les 2 touches du PAD pour simuler la touche médiane de la souris sur le PAD (ce qui marchait sur le PAD avant que la touche droite ne tombe en panne).

j'utilise une souris extérieure, mais la touche médiane ne sert vraiment que de molette.

alors, pour copier-coller, j'utilise cette souris, sa touche droite pour "copier" et dans l'autre fenêtre à nouveau la touche droite pour "coller".

mais cela ne marche pas dans xterm. il faut un terminal évolué tel que sakura ou rox-term. alors, là, ça va.

mais cards me répond:

cards 2.0 install: The package sakura does not exist
cards 2.0 install: The package rox-term does not exist
cards 2.0 install: The package rox-terminal does not exist

quel autre terminal évolué puis-je installer (mais pas "konsole", je ne veux pas installer KDE uniquement pour avoir un terminal évolué!)?

cordialement

pierre^

  • Moderator
  • Full Member
  • *****
  • Messages: 152
  • Karma: 2
Re : terminal évolué (sakura, rox-term ou autre)
« Réponse #1 le: dim. avril 10 17:48:13 2016 »
Il y a quand même le choix :

pierre [ ~/NuTyX/git/core ]$ cards  search rox
(cli-extra) nginx 1.6.2 nginx [engine x] is a high-performance HTTP server and reverse proxy,
(gui-extra) rox-filer 2.11 Small and fast file manager which can optionally manage the desktop background and panels
(gui-extra) roxterm 3.3.1 Tabbed, VTE-based terminal emulator
pierre [ ~/NuTyX/git/core ]$


ierre [ ~/NuTyX/git/core ]$ cards  search terminal
(base) ncurses 6.0 Libraries for terminal-independent handling of character screens.
(cli) libutempter 1.1.6 Interface for terminal emulators to record user sessions to utmp and wtmp files.
(cli) tmux 2.0 A terminal multiplexer
(cli-extra) irssi 0.8.16 Irssi is a terminal based IRC client for UNIX systems.
(cli-extra) screen 4.3.1 Runs several separate processes on a single physical character-based terminal.
(gnome-extra) gnome-terminal 3.18.2 The GNOME Terminal Emulator.
(gui) vte 0.28.2 Vte is a library (libvte) implementing a terminal emulator widget for GTK+ 2
(gui) vte3 0.42.1 Vte is a library (libvte) implementing a terminal emulator widget for GTK+ 3
(gui) xorg-term 324 xterm is a terminal emulator for the X Window System.
(gui-extra) qtermwidget 20130206 Terminal Widget based on qt4
(gui-extra) rdesktop 1.8.2 allows access the terminal windows
(gui-extra) roxterm 3.3.1 Tabbed, VTE-based terminal emulator
(gui-extra) rxvt-unicode 9.20 An enhanced unicode capable version of the rxvt terminal emulator.
(gui-extra) st 0.6 st is a simple terminal implementation for X
(gui-extra) stfl 0.24 Library which implements a curses-based widget set for text terminals
(kde5-extra) konsole 15.12.3 Terminal
(lxde-extra) lxde-terminal 0.2.0 n.a.
(mate-extra) mate-terminal 1.12.1 Terminal MATE
(xfce4-extra) xfce4-terminal 0.6.3 Terminal emulator from Xfce4.
pierre [ ~/NuTyX/git/core ]$

PS : man nutyx et man cards donnent de précieuses informations :-D
« Modifié: dim. avril 10 17:54:14 2016 par pierre^ »

tnut

  • Administrator
  • Hero Member
  • *****
  • Messages: 622
  • Karma: 4
    • NuTyX distribution
Re : terminal évolué (sakura, rox-term ou autre)
« Réponse #2 le: dim. avril 10 18:45:46 2016 »
comme à mon habitude, c'est vers le weekend que je tente la construction.
...

cards 2.0 install: The package sakura does not exist
cards 2.0 install: The package rox-term does not exist
cards 2.0 install: The package rox-terminal does not exist

Est-ce que tu souhaites construire une NuTyX et ses ports ou souhaites-tu installer?

Si c'est la commande:
cards install xxxxque tu essaies, je te mets un extrait de:

man cards
      install [--margs] <package1> [<package2> ...] | <collection name>
              Binaries scenario: install all packages. It will download the  binary  package,  check  for  any
              dependencies,  download  the  dependencies.  Onces all the dependencies are download. cards will
              install all the packages in the right order. If it's a <collection name> passed as argument,  it
              will installed all the packages belonging to this <collection name>

On parle bien de binaires donc

Pour pouvoir installer des binaires, cards DOIT connaître l'url où télécharger ceux-ci. Si tu as (comme je crois comprendre réalisé une NuTyX depuis 0 et que tu as copié le cards.conf du tuto. Ton cards.conf ne contient aucune URL

Je rejoins  sh4d0w, essais d'y allet crechendo.

J'ai expressement mis l'article en dernier car c'est de loin le plus complexe.

Je crois que tu devrais les prendres dans l'ordre de http://www.nutyx.org/fr/documentation.html