INSTALLATION > Depuis le script

[Script Install] bloqué sur getPackageFileName

(1/2) > >>

tuk0z:
Bonjour. J'ai lancé le script ce soir, des semaines après avoir lu sur NuTyX et être curieux d'essayer la distro. Pour la petite histoire je participe à un Café repair orienté logiciels libres et ré-emploi ; on a la moitié des ressources pour passer à l'étape FabLab fauché ;) suis administrateur GNU/Linux (parfois l'inverse) depuis 15 ans. Alors désolé de commencer ma vie de membre du forum par une question que j'ai peu approfondie. C'est que :

Script d'installation NutyX téléchargé d'aujourd'hui ; `md5sum -c` OK ; lancé sur une AntiX 16 (Debian 8.0) sous qemu.

--- Code: ---root@antix16:/home/tux# uname -romi
4.8.0-2.1-liquorix-686 i686 unknown GNU/Linux

# bash --version
GNU bash, version 4.3.30(1)-release (i586-pc-linux-gnu
                                                                                 
# curl --version                                                                 
curl 7.38.0 (i586-pc-linux-gnu) libcurl/7.38.0 OpenSSL/1.0.1t zlib/1.2.8 libidn/1.29 libssh2/1.4.3 librtmp/2.3

# mount|grep hd
/dev/sda11 on /mnt/hd type ext4 (rw,relatime,data=ordered)

# ls -l install-nutyx
-rwxr-xr-x 1 tux tux 41850 févr. 27 23:36 install-nutyx

# bash install-nutyx
LFS        : /mnt/hd                                                               
DEVICE     : /mnt/hd                                                               
URL        : http://downloads.nutyx.org                                             
VERSION    : 10.0                                                                   
KERNEL     : linux-firmware sysklogd sysvinit reiserfsprogs e3 grub lz4 mdadm jfsutils xfsprogs btrfs-progs dhcpcd kernel-lts
DEPOT      : /var/lib/pkg/depot                                                     
MOUNT      :                                                                       
FOLDER     : /mnt/hd                                                               
DEPOT_BASE : http://downloads.nutyx.org/i686/10.0/base                             
DEVEL      :                                                                       
CHROOT_LIST: nutyx acl attr bash bzip2 coreutils curl expat gcc readline ncurses lzo glibc gmp xz zlib libarchive mpc mpfr openssl cards
                                                                                   
 variable 'PackageFileName' is not set                                             
                                                                                   
umount: /mnt/hd//var/lib/pkg/depot: not mounted                                     
Cleaning up temporary files..                                                       
Please correct and start again 
--- Fin du code ---
Là ça se passe apparemment ligne 223 : `getPackageFileName() {` mais je suis pas au fait des trucs pour aller plus loin : curl est installé avec la version ci-dessus sur ma distro de départ.
Un conseil pour passer l'étape SVP ?

Thierry:
Salut  tuk0z

C'est super cool de ta part d'essayer le script et me retourner autant de détails. C'est un cas intéressant.

Je vois que tu tests en version 32bits.
Ya t-il une raison particulière ?
D'autre part, l'usage du script s'adresse aux habitués de NuTyX.

Je penche pour une version de Bash ou de Curl obsolète mais pas sûr

tuk0z:
C'est un peu détaillé car j'ai pas su aller plus loin solo ;)
Tu souhaites que je réessaie après MÀJ via un Backport Debian, ou je passe directement à l'ISO ?

En fait 80% des machines qu'on expose / prête / vend toutes configurées (à tarif de super pote hein) au Café Répare sont des i686, et même avec une moyenne de 1 GB RAM. Ces machines tournent remarquablement bien sous par ex, AntiX ou Bodhi configurés avé les dernières versions de tous les softs « basiques ».

EDIT Retour en ayant lancé le script sous MX 17 (Debian 9) / qemu :

Bash v4.4.12
Curl v7.52.1
Même blockage sur 'getPackageFileName is not set'.

J'ai crû lire sur le salon Install ISO que la version i686 est laissée de côté avec NuTyX 10 (ce qui fait sens d'un point de vue dév). Du coup pour ma veille en distros légères x86_32 et francophones when possible je ferai fausse route ?

Thierry:

--- Citer --- je passe directement à l'ISO ?

--- Fin de citation ---
Oui, tu auras beaucoup moins de soucis. Le script d'install c'est vraiment pour les barbus (même si ton bug n'a rien à voir).

Prends directement L'ISO MATE par exemple

guy_:
Salut,

Apparement le DEPOT_BASE http://downloads.nutyx.org/i686/10.0/base n' existe plus pour la 10.0 !!!

Navigation

[0] Index des messages

[#] Page suivante

Utiliser la version classique