Auteur Sujet: Une suggestion  (Lu 211 fois)

Raustone

  • Petit Nouveau
  • *
  • Messages: 19
  • Karma: 0
  • Sexe: Homme
Une suggestion
« le: mar. août 07 08:25:24 2018 »
Bonjour,
j'ai une suggestion pour le gestionnaire de paquets cards, pouvez-vous adapter gnome-software pour cards ?
Perso je n'aime pas trop l'interface de flcards ...

Bonne journée a vous.
Raustone

Thierry

  • Administrator
  • Super Héros
  • *****
  • Messages: 1022
  • Karma: 10
  • Sexe: Homme
    • NuTyX distribution
Re : Une suggestion
« Réponse #1 le: mar. août 07 08:37:50 2018 »
C'est toujours possible, après il faut trouver le temps pour l'implémenter.
Extrait du wikipedia:

"It is the GNOME front-end to the PackageKit daemon, which itself is a front-end to several package management systems. "

Sachant que je voulais un jour commener par développer le "front-end" de PackageKit pour cards. J'ai maintenant une motivation en plus

Raustone

  • Petit Nouveau
  • *
  • Messages: 19
  • Karma: 0
  • Sexe: Homme
Re : Une suggestion
« Réponse #2 le: mar. août 07 08:50:02 2018 »
Sinon je te propose de coder une interface plus propre avec glade.
Raustone

Thierry

  • Administrator
  • Super Héros
  • *****
  • Messages: 1022
  • Karma: 10
  • Sexe: Homme
    • NuTyX distribution
Re : Une suggestion
« Réponse #3 le: mar. août 07 09:07:28 2018 »
Sinon je te propose de coder une interface plus propre avec glade.
Peux-tu développer ton idée?

Raustone

  • Petit Nouveau
  • *
  • Messages: 19
  • Karma: 0
  • Sexe: Homme
Re : Une suggestion
« Réponse #4 le: mar. août 07 09:14:17 2018 »
oui j'ai commencé à construire le paquet glade mais j'ai cette erreur que je n'arrive pas à corriger :

checking for XML::Parser... ok
checking how to copy va_list... va_copy
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for gtk-doc... no
configure: WARNING:
  You will not be able to create source packages with 'make dist'
  because gtk-doc >= 1.13 is not found.
checking for gtkdoc-check... no
checking for gtkdoc-check... no
checking for gtkdoc-rebase... no
checking for gtkdoc-mkpdf... no   [10:56 x86_64 4.14.59-NuTyX-lts lilian@nutyx]
checking whether to build gtk-doc documentation... no
checking for GTKDOC_DEPS... no
checking for gobject-introspection... no
checking for GTK... no
configure: error: Package requirements (
  gtk+-3.0 >= 3.20.0
  gmodule-2.0
  libxml-2.0 >= 2.4.0
) were not met:
 
No package 'gtk+-3.0' found
No package 'gmodule-2.0' found
No package 'libxml-2.0' found
 
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.
 
Alternatively, you may set the environment variables GTK_CFLAGS
and GTK_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
=======> ERROR: Building '/usr/ports/mes_paquets/3.20.4/glade/glade1533632690x86_64.cards.tar.xz' failed.
Raustone

Raustone

  • Petit Nouveau
  • *
  • Messages: 19
  • Karma: 0
  • Sexe: Homme
Re : Une suggestion
« Réponse #5 le: mar. août 07 09:16:17 2018 »
voici la recette :

# Depends on: gtk3 libxml2
 
description="User Interface Builder for GTK+ applications"
url="https://glade.gnome.org/"
maintainer="Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>"
packager="Raustone"
 
_name=glade
 
name=glade
version=3.20.4
release=6
 
source=(http://ftp.gnome.org/pub/GNOME/sources/glade/3.20/glade-3.20.4.tar.xz)
build() {
cd ${_name}-$version
./configure --prefix=/usr \
--disable-static
make
make DESTDIR=$PKG install
}
Raustone