Auteur Sujet: pas de son quand firefox est lancé dans un firejail  (Lu 646 fois)

dania5583

  • Membre Senior
  • ****
  • Messages: 121
  • Karma: 3
Re : pas de son quand firefox est lancé dans un firejail
« Réponse #15 le: lun. sept. 24 15:33:55 2018 »
Bonjour Guy

J'ai trouvé ce lien et ça marche avec openbox. Visiblement le problème vient de pulseaudio au démarrage

https://lazymalloc.com/index.php/2017/04/08/making-pulseaudio-10-work-with-x-windows-and-firejail/

ça a marché sur une VM openbox et un portable avec openbox en faisant

pulseaudio -k
start-pulseaudio-x11


par contre ça ne marche pas avec
pulseaudio -k
pulseaudio -D ou pulseaudio --start

Thierry pourra peut-etre nous indiquer la différence entre les deux commandes start-pulseaudio-x11 et pulseaudio -D (daemon start)

La personne qui a trouvé l'astuce a inclus les commandes dans son xinitrc

Cordialement

Daniel

Vraiment ce problème je ne l'aurai jamais trouvé



guy_

  • Membre Senior
  • ****
  • Messages: 103
  • Karma: 4
Re : pas de son quand firefox est lancé dans un firejail
« Réponse #16 le: lun. sept. 24 18:08:56 2018 »
Bonsoir Daniel,

Le problème est résolu chez moi aussi.
Merci d'avoir cherché sur mon problème et trouvé la solution.

Guy

Thierry

  • Administrator
  • Super Héros
  • *****
  • Messages: 1065
  • Karma: 10
  • Sexe: Homme
    • NuTyX distribution
Re : pas de son quand firefox est lancé dans un firejail
« Réponse #17 le: sam. sept. 29 22:29:03 2018 »
Salut,

La commande start-pulseaudio-x11 est un script pas trop complexe. Il charge quelques modules. Il se trouve dans /usr/bin/start-pulseaudio-x11. Il existe une page man.
get pulseaudio.man
L'option -D que tu passes à la commande pulseaudio -D démarre le service pulseaudio en mode démon (deamon)

Plus d'info sur BLFS

http://www.linuxfromscratch.org/blfs/view/svn/multimedia/pulseaudio.html
« Modifié: sam. sept. 29 22:38:56 2018 par Thierry »