Forum des utilisateurs NuTyX

INSTALLER => Depuis le script => Discussion démarrée par: cubitux le jeu. mars 01 17:21:20 2018

Titre: libreoffice 6 ne se lance pas sous mate
Posté par: cubitux le jeu. mars 01 17:21:20 2018
Version NuTyX 10.1 chargée par le script  (seule solution sur mon Lenovo y700)
Mate installé;     libreoffice installé:  mais ne démarre pas (version 6)
Enfin j'aimerais bien pouvoir régler la luminosité !     Pour le son ça marche
Titre: Re : libreoffice 6 ne se lance pas sous mate
Posté par: Thierry le jeu. mars 01 20:29:23 2018
Je confirme, demain (si tout va bien) libreoffice sera mis à jour
Titre: Re : libreoffice 6 ne se lance pas sous mate
Posté par: cubitux le jeu. mars 08 07:53:45 2018
Bonjour, après de multiples réinstallation, LibreOffice ne fonctionne toujours pas ?
Titre: Re : libreoffice 6 ne se lance pas sous mate
Posté par: Thierry le jeu. mars 08 17:29:54 2018
Il fonctionne nickel chez moi.

Lances le dans un terminal pour voir ce qu'il dit
Titre: Re : libreoffice 6 ne se lance pas sous mate
Posté par: fanch le ven. mars 09 08:57:45 2018
Je ne l'ai pas essayé sous mate mais sous gnome 3.26.2 en version 10.1, ça se lance sans souci.  :)
Par contre, j'ai aussi le problème de réglages de la luminosité. La barre de réglage bloque et la luminosité reste bloqué presque à fond.
A part c'est quelques petits problèmes, je suis agréablement surpris par cette version de gnome 3.26.

Par ailleurs, j'ai un problème plus personnel. Il est lié à mon ordinateur portable. Pour installer, nutyx gnome 3.26 version 10.1, j'ai été obligé d'utiliser la mini 9.0 et en suite de modifier la version en mettant à jour vers 10.1. En effet, les versions 10 ne prennent pas en compte le wifi de mon portable alors que la version 9 ne posait aucun problème.

En tous les cas, chapeau bas à NuTyX, il faut reconnaitre que maintenir gnome en systemV, ce n'est pas une mince affaire. Merci encore et à bientôt
Titre: Re : libreoffice 6 ne se lance pas sous mate
Posté par: cubitux le sam. mars 10 08:47:35 2018
Bonjour, en mode terminal, libreoffice répond:      /usr/lib/libreoffice/program/soffice.bin : error while loading shared libraries:   libboost_locale.so.1.64.0       n'existe pas.

Comment rajouter cette bibliothèque partagée ?
Titre: Re : libreoffice 6 ne se lance pas sous mate
Posté par: Thierry le sam. mars 10 11:01:04 2018
Comment rajouter cette bibliothèque partagée ?En mettant ton système à jour

check
sudo cards upgrade

....

 AJOUTE: (gui-extra) libreoffice 6.0.2.1-1, 6822 fichiers: 100 %
...

Vérifie que c'est bien les mêmes versions chez toi
Titre: Re : libreoffice 6 ne se lance pas sous mate
Posté par: dania5583 le sam. mars 10 12:03:05 2018
Bonjour j'ai upgradé mon portable de 9.1 à 10.0 et puis j'ai passé de la 10.0 stable à la version 10.0 current avec Mate . J'ai utilisé l'image iso de base . Il n'y a pas eu de problème libreoffice est passé de la version 5 à la version 6 et fonctionne. Ensuite j'ai installé une VM  en 10.1-rc1 sous virtualbox et libreoffice en version 6 fonctionne.

Pour le problème de Fanch avec son pc portable ,je n’étais pas chez moi quand j'ai upgradé mon portable en 10.0. L'installation était derrière une box Orange .J'ai rentré dans l'installateur le nom de la box  puis sa clé de sécurité dans le passphrase .Quand j'ai eu le premier login je suis passé en root mais le check est parti en erreur de download. J'ai pu m'en sortir en faisant
ip link set wlp1s0 up
dhcpcd wlp1s0
ping www.google.fr  --> ping OK

visiblement cela à suffit par contre après sous Mate il a fallut rentrer en dur la clef wifi dans les paramètres réseau concernant la connexion wifi

Cordialement

daniel
Titre: Re : libreoffice 6 ne se lance pas sous mate
Posté par: dania5583 le dim. mars 11 10:16:29 2018
j'avais oublié de signaler le plus important pour fanch

ip link set wlp1s0 up
rfkill list --> wifi bluetooth ethernet bloqué softwarement
rfkill unblock 0
rfkill unblock 1
rfkill unblock 2
rfkill unblock 3  ou alors rfkill unblock all
dhcpcd wlp1s0
ping www.google.fr 

cordialement
Titre: Re : libreoffice 6 ne se lance pas sous mate
Posté par: cubitux le dim. mars 11 14:15:49 2018
Bonjour, cards me dit que "libreoffice 6.0.2.1-1 n'existe pas, seulement 6.0.1.1-1
et toujours libboost_locale.so.1.64.0 manquant.
sudo cards upgrade me dit : système à jour   

Lenovo Y700
Titre: Re : libreoffice 6 ne se lance pas sous mate
Posté par: dania5583 le dim. mars 11 18:31:28 2018
en 10.0         libreoffice 6.0.1.1
en 10.1-rc1  libreoffice 6.0.2.1

fais peut-être un get boost (boost 1.64.0-1)

Titre: Re : libreoffice 6 ne se lance pas sous mate
Posté par: cubitux le lun. mars 12 07:58:16 2018
jbg [ ~/Desktop ]$ get boost
Obtenir les infos sur les 401 paquets: 100 %
SUPPRIME: (cli) boost 1.66.0-1, 75 fichiers: 100 %
  AJOUTE: (cli) boost 1.66.0-1, 77 fichiers: 100 %
post-installation: démarrée
  /sbin/ldconfig -r /
post-installation: finie
jbg [ ~/Desktop ]$ libreoffice
/usr/lib/libreoffice/program/soffice.bin: error while loading shared libraries: libboost_locale.so.1.64.0: cannot open shared object file: No such file or directory

En fait il s'agit de boost 1.66 qui est installé, j'ai l'impression que libreoffice cherche boost 1.64.
Titre: Re : libreoffice 6 ne se lance pas sous mate
Posté par: Thierry le lun. mars 12 08:37:48 2018
cards config donne quoi ?
Titre: Re : libreoffice 6 ne se lance pas sous mate
Posté par: cubitux le lun. mars 12 16:04:38 2018
Bonjour, j'ai recommencé l'installation complète par le script: version development
Et cette fois libreoffice fonctionne
Mais j'ai d'énormes difficultés à démarrer sur la NuTyX : pourtant bien reconnue par le grub de la Mint   (update-grub)
Je suppose que UEFI fait des siennes mais quoi ?
Titre: Re : libreoffice 6 ne se lance pas sous mate
Posté par: cubitux le mar. mars 13 19:11:47 2018
bonsoir, dernières nouvelles concernant le lancement difficile de Nutyx.
Il faut avec GPARTED "gérer les drapeaux" des disques: dans ce cas il faut cocher "boot" et "efi" (ce dernier se coche automatiquement après "boot").

Pour régler la luminosité sous MATE, il faut installer "xorg-xrandr
Trouver d'abord le nom de l'écran: $find /sys/ -type f -iname '*brightness*'
Ce qui me donne au milieu d'une longue ligne : "eDP-1"

Je baisse la luminosité de 30% avec la commande: $xrandr --output eDP-1 --brightness 0.7
Tout semble fonctionner,mais il m' fallu repartir de zéro avec le script
Titre: Re : libreoffice 6 ne se lance pas sous mate
Posté par: dania5583 le jeu. mars 15 10:41:54 2018
Bonjour
Pour régler la luminosité il y a aussi backlight (get xorg-xbacklight) pour gérer la luminosité mais ça n'a l'air de marcher qu'avec Intel et pas les puces radeon
voir le lien Archlinux https://wiki.archlinux.org/index.php/backlight#xbacklight

voir ce qu'il y a dans le répertoire /sys/class/backlight

J'ai un petit acer aspire one les touches de luminosité fonctionnent par contre mon Lenovo avec une puce radeon non
Titre: Re : libreoffice 6 ne se lance pas sous mate
Posté par: fanch le ven. mars 16 19:33:58 2018
Merci pour xorg-xbacklight, tu peux aussi utiliser xorg-xrandr pour régler la luminosité en ligne de commande.
j'ai essayé plusieurs bureaux, le seul qui me permet de régler la luminosité : c'est enlightment. Pour les autres bureaux, je cherche et j'avoue que pour le moment, je suis un peu bloqué.

A suivre et merci encore pour tes info Dania5583  ;)
Titre: Re : libreoffice 6 ne se lance pas sous mate
Posté par: dania5583 le sam. mars 17 10:46:32 2018
Bonjour Fanch

Mon petit Acer (32  bits) est aussi sous Enlightenment. Backlight doit être intégré dedans. j'ai trouvé aussi ces lien parmi tant d'autres

http://www.christophe-meneses.fr/article/installer-ubuntu-sur-un-ordinateur-portable-asus-zenbook-ux303ln
https://askubuntu.com/questions/540911/how-to-adjust-screen-brightness-in-ubuntu-14-04-trusty-tahr

si ton laptop utilise grub tu peux essayé de mettre acpi_osi= derrière quiet dans /boot/grub/grub.cfg. Personnellement il n'y a pas grub sur mon laptop en uefi.

Pour plus d'info essaye
cd /sys
find / -name '*brightness*'
find / -name '*backlight*'

sinon pour xbacklight

xbacklight -set 50
xbacklight -inc 10
xbacklight -dec 10

Cordialement

daniel



Titre: Re : libreoffice 6 ne se lance pas sous mate
Posté par: Thierry le sam. mars 17 10:54:41 2018
C'est super sympa,
merci pour toutes ces informations les amis.
C'est chouette

BàV
Thierry
Titre: Re : libreoffice 6 ne se lance pas sous mate
Posté par: fanch le sam. mars 17 16:15:51 2018
Dans le même ordre d'idée avec la commande xrandr :

xrandr --output "ton écran" --brightness 0.5


tu tapes la commande xrandr, ça te permet de récupèrer le nom de l'écran. Par exemple sur mon portable  est LVDS1 donc on obtient xrandr --output LVDS1 --brightness 0.5.
Aprés on peut changer la variable pour plus ou moins de luminosité.

En tous les cas, merci pour tes réponses, si ça ne m'aide pas diretement pour le moment, ça donne des idées et ça peut aider un autre utilisateur.

Nota : pour utiliser xbacklight et xrandr, il faut installer xorg-xrandr ou xorg-backlight

Bon essai

Titre: Re : libreoffice 6 ne se lance pas sous mate
Posté par: dania5583 le dim. mars 18 15:36:22 2018
Bonjour
Comment se faire piéger et revenir au point de départ. J'avais constaté que les touches F11 et F12 pour régler la luminosité ne fonctionnaient pas. Quelle fut ma surprise de voir que toutes les touches liées à la touche Fn n'avaient pas d'action (pas de wifi de réglage de son mode avion etc ...) En fait elles fonctionnent, dans le bios il y a une option Hotkey enable qui permet d'utiliser F1,F2 ... au lieu de FN+F1,Fn+F2 ... Donc quand j'ai appuyé sur F11 (diminuer la luminosité) un petit OSD en forme de soleil avec une barre de progression est apparu sur l'écran mais la luminosité ne diminue pas
une action sur la touche F12 (augmenter la luminosité) est sans effet et pas d'OSD.

la commande xmodmap -pke me donne
keycode 232 = XF86MonBrightnessDown
keycode 233 = XF86MonBrightnessUp

pour avoir les keycodes on installe get xorg-xev et on fait

xev | sed -n 's/.*keycode *\([0-9]\+\)[^,]*, \([^)]\+\)).*$/keycode \1, keysym \2/p'

ou xev tout court et la je ne vois pas de rapport avec la luminosité

F11 keycode 95
F12 keycode 96

ou est fait le mapping

Cordialement

daniel

Titre: Re : libreoffice 6 ne se lance pas sous mate
Posté par: dania5583 le dim. mars 18 17:40:27 2018
ça avance

en se loggant sous root l'OSD marche avec les touches F11 et F12 on peut augmenter ou diminuer la luminosité la luminosité .Par contre dans les préférences de gestion d’énergie la barre de réglage de luminosité ne bouge pas et semble indépendante des touches F11 et F12 . Cette barre doit définir la luminosité max voulue au boot.

Maintenant pourquoi un utilisateur lambda n'a pas les droits