Forum des utilisateurs NuTyX

CONFIGURATION => Le son => Discussion démarrée par: guy_ le mar. sept. 11 19:02:51 2018

Titre: pas de son quand firefox est lancé dans un firejail
Posté par: guy_ le mar. sept. 11 19:02:51 2018
Bonjour,

Quand je lance firefox dans un firejail
firejail firefoxje n'ai pas de son!

Jai bien vu sur google que ce problème est récurent et n'affecte pas que NuTyX.
Cependant d'autres distrivbutions s'en sortent bien sans configuration particulière à faire.

Quelqu'un a t'il une suggestion pour résoude ceci sous nutyx stable?

Guy
Titre: Re : pas de son quand firefox est lancé dans un firejail
Posté par: dania5583 le mer. sept. 12 12:07:09 2018
Bonjour Guy
Je viens de tester dans une VM fixed et une VM rolling en Nutyx 10.3 et je n'ai pas eu de problème de son (test d'une video sous Youtube). Le seul problème que j'ai eu à l'ouverture de la fenêtre sous Youtube le son est dé-validé il faut cliquer sur l'icone de son.

j'utilise mate avec pulseaudio. Sinon il y a ce lien sous Archlinux avec la commande firecfg

https://wiki.archlinux.org/index.php/firejail#PulseAudio

Cordialement

Daniel
Titre: Re : pas de son quand firefox est lancé dans un firejail
Posté par: guy_ le mer. sept. 12 13:47:06 2018
Bonjour dania5583,

Merci pour ta réponse.

Malheureusement aucune des 2 propositions n'a solutionné le problème.
Je ne travaille pas dans une VM, c'est dans une installation "en dur",
J'utilise openbox et pulseaudio.
J'ai bien le son quand je lance firefox directement  (sans firejail).

Guy
Titre: Re : pas de son quand firefox est lancé dans un firejail
Posté par: dania5583 le mer. sept. 12 19:02:27 2018
Bonsoir Guy
j'ai créé une VM avec l'iso fixed 10.3 j'ai installé une nutyx avec openbox et là j'ai effectivement ton problème firefox marche normalement mais pas de son à travers firejail. Dans le terminal il y a des erreurs à l'initialisation de l'audiostream. Si ça marche sous Mate et pas sous Openbox il doit manquer quelque chose une dépendance mais je ne sais pas laquelle pour le moment

Cordialement

Daniel
Titre: Re : pas de son quand firefox est lancé dans un firejail
Posté par: guy_ le sam. sept. 15 19:02:56 2018
Bonsoirl,

Je n'ai pas encore réussi à résoudre ce manque de son,
mais je me demande si ce n'est pas plutôt un problème de profil,
car si je lance

firejail --noprofile firefox

le son fonctionne.
Evidemment on perd ainsi l'intérêt du sanboxing firejail.


Guy
Titre: Re : pas de son quand firefox est lancé dans un firejail
Posté par: dania5583 le dim. sept. 16 16:25:10 2018
Bonsoir Guy
Avec une vm de base lxdm openbox pavucontrol firefox firejail  j'ai le son quand je lance firefox et toujours pas à travers firejail quelquesoit l'option. Par contre pas de problème avec une vm Mate. C'est toujours la même erreur d'initialisation opencubeb mais il n' y a pas grand chose sur le net

Cordialement
Titre: Re : pas de son quand firefox est lancé dans un firejail
Posté par: Thierry le lun. sept. 17 15:11:48 2018
@guy refais le test après un:

get mate mate-extra
Tu pourras toujours supprimer les 2 collections. Ensuite on saura quelle dépendance il nous manque à firejail
Titre: Re : pas de son quand firefox est lancé dans un firejail
Posté par: guy_ le lun. sept. 17 18:25:14 2018
Bonsoir Thierry, Daniel,

J'ai bien installé mate mate-session.

Sous openbox, évidemment rien de changé, toujous pas de son avec
firejail firefox
Quand je lance mate en modifiant mon .xinitrc, mate démarre mais le pc se fige, je dois retourner dans une console (CTRL+ALT+F2) et killer X avec
kill `pidof xinit`
Manque t'il quelque chose à mon .xinitrc?
Voici le contenu dans mon .xinitrc
openbox-session
## exec mate-session

Guy
Titre: Re : pas de son quand firefox est lancé dans un firejail
Posté par: dania5583 le lun. sept. 17 19:14:40 2018
Bonsoir Guy et Thierry

Guy tu devrais installer lxdm pour pouvoir choisir le type de session soit Mate soit Openbox. Maintenant j'ai installé un pc avec lxdm openbox et mate
Si je démarre sous mate le son est présent dans firejail firefox ,par contre si je change de session et démarre avec openbox toujours pas de son avec firejail firefox. ça ne semble plus etre un problème de dépendance (openbox devrait voir tous les paquets installés normalement ?)

j'ai bien essayé de modifier les fichiers /etc/firejail/firefox.profile et firefox-common.profile mais sans succès . La structure dans openbox doit etre differente

Cordialement

Daniel
Titre: Re : pas de son quand firefox est lancé dans un firejail
Posté par: Thierry le mar. sept. 18 07:59:01 2018
Je crois que comme pour Xfce4 sans gestionnaire de session, il faut passer la commande:

ck-launch-session dbus-launch --exit-with-session mate-session
dans ton .xinitrc

Tiens nous au courant

Source: http://www.linuxfromscratch.org/blfs/view/svn/xfce/xfce4-session.html, Paragraphe: "Starting Xfce4"
Titre: Re : pas de son quand firefox est lancé dans un firejail
Posté par: guy_ le mer. sept. 19 07:28:00 2018
Bonjour Thierry, Daniel,,

Décidément,je collectionne les problèmes...

J'ai démarré mate
- avec le .xinitrc suggéré par tnut
- avec slim comme suggéré par Daniel
Chaque fois frefox se plante '<defunct>'.

guy [ ~ ]$ ps -ef | grep fire
root       405     2  0 08:15 ?        00:00:00 [firewire]
root       407     2  0 08:15 ?        00:00:00 [firewire_ohci]
guy       7947  7773  0 08:57 pts/0    00:00:00 firejail firefox
guy       7948  7947  0 08:57 pts/0    00:00:00 firejail firefox
guy       7957  7948  0 08:57 pts/0    00:00:00 firefox
guy       7960  7957  0 08:57 pts/0    00:00:00 [firefox] <defunct>
guy       8138  7962  0 08:57 pts/1    00:00:00 grep --color fire

Sinon, j'ai essayé aussi en recompilant la dernière version de fiirejail (0.9.56), rien n'y fait, pas de son.
J'ai également les messages OpenCubeB failed:

Child process initialized in 95.88 ms
1537341344077 addons.webextension.https-everywhere@eff.org WARN Please specify whether you want browser_style or not in your browser_action options.
Log warning: The log 'Services.Common.RESTRequest' is configured to use the preference 'services.common.log.logger.rest.request' - you must adjust the level by setting this preference, not by using the level setter
[Child 55, MediaPlayback #1] WARNING: 7fbec7bcb4c0 OpenCubeb() failed to init cubeb: file /tmp/work/src/firefox-61.0.1/dom/media/AudioStream.cpp, line 390
[Child 55, MediaPlayback #1] WARNING: Decoder=7fbec2bf8d40 [OnMediaSinkAudioError]: file /tmp/work/src/firefox-61.0.1/dom/media/MediaDecoderStateMachine.cpp, line 3716

Merci d'avoir cherché sur mon problème,
en espérant une solution,

Guy
Titre: Re : pas de son quand firefox est lancé dans un firejail
Posté par: dania5583 le jeu. sept. 20 19:02:37 2018
Bonsoir Guy
J'avais aussi compilé la version  firejail 9.56 sans succès.
quand je lançais firejail firefox il y avait une erreur libg-error que j'ai éliminé en installant le paquet dconf .Dans /var/log/sys.log il y avait une erreur bluez5.c que j'ai éliminé en enlevant les références au bluetooth (je n'en ai pas) dans le fichier /etc/pulse/default.pa. J'ai installer le paquet asio (audio stream input output) le son à marché si je ne me suis pas croisé les yeux mais ça a disparu au reboot suivant. Maintenant je n'ai plus d'erreur dans sys.log sauf une perte de performance du kernel à chaque essai mais toujours pas de son

 à suivre
Cordialement

Daniel
Titre: Re : pas de son quand firefox est lancé dans un firejail
Posté par: dania5583 le ven. sept. 21 16:46:28 2018
firejail chromium dans openbox aucun problème de son
je vais comparer les profils de firefox et chromium dans /etc/firejail
Titre: Re : pas de son quand firefox est lancé dans un firejail
Posté par: guy_ le sam. sept. 22 10:55:04 2018
Bonjour Daniel,

Ton dernier post a succité tout mon intéret.

Comme tu l'as suggéré, jai comparé les profils de firefox et de chromium:
     En commentant la ligne 'seccomp.drop ...' dans le fichier /etc/firejail/firefox-common.profile,
     le son fonctionne !

Il reste évidemment à affiner cela question sécurité, mais ton aide a été bien précieuse.
Je vais étudier ce lien: https://firejail.wordpress.com/documentation-2/seccomp-guide/ (https://firejail.wordpress.com/documentation-2/seccomp-guide/)

Guy
Titre: Re : pas de son quand firefox est lancé dans un firejail
Posté par: dania5583 le sam. sept. 22 14:05:15 2018
Bonjour Guy

Ce que je comprends de seccomp c'est un gros filtre de sécurité . Comme tu le supprime ça a l'air de marcher .Maintenant sous Mate pas de problème . En fait le filtrage doit toucher quelque-chose sous openbox qui empêche l'audiostream (audioIPC server de fonctionner) tu le vois sous pavucontrol dans l'onglet lecture si tu lances firefox il y a une icone firefox  avec des jauges par-contre rien avec firejail firefox . et je n'ai rien trouvé sur le net j'ai essayé de valider des répertoires dans le fichier firefox.profile mais sans succès
il n'y a pas à première vue de filtre seccomp sous chromium donc ça marche

Cordialement

Daniel
Titre: Re : pas de son quand firefox est lancé dans un firejail
Posté par: dania5583 le lun. sept. 24 15:33:55 2018
Bonjour Guy

J'ai trouvé ce lien et ça marche avec openbox. Visiblement le problème vient de pulseaudio au démarrage

https://lazymalloc.com/index.php/2017/04/08/making-pulseaudio-10-work-with-x-windows-and-firejail/

ça a marché sur une VM openbox et un portable avec openbox en faisant

pulseaudio -k
start-pulseaudio-x11

par contre ça ne marche pas avec
pulseaudio -k
pulseaudio -D ou pulseaudio --start

Thierry pourra peut-etre nous indiquer la différence entre les deux commandes start-pulseaudio-x11 et pulseaudio -D (daemon start)

La personne qui a trouvé l'astuce a inclus les commandes dans son xinitrc

Cordialement

Daniel

Vraiment ce problème je ne l'aurai jamais trouvé


Titre: Re : pas de son quand firefox est lancé dans un firejail
Posté par: guy_ le lun. sept. 24 18:08:56 2018
Bonsoir Daniel,

Le problème est résolu chez moi aussi.
Merci d'avoir cherché sur mon problème et trouvé la solution.

Guy
Titre: Re : pas de son quand firefox est lancé dans un firejail
Posté par: Thierry le sam. sept. 29 22:29:03 2018
Salut,

La commande start-pulseaudio-x11 est un script pas trop complexe. Il charge quelques modules. Il se trouve dans /usr/bin/start-pulseaudio-x11. Il existe une page man.
get pulseaudio.man
L'option -D que tu passes à la commande pulseaudio -D démarre le service pulseaudio en mode démon (deamon)

Plus d'info sur BLFS

http://www.linuxfromscratch.org/blfs/view/svn/multimedia/pulseaudio.html