Messages récents

Pages: 1 ... 8 9 [10]
91
Avant de vous lancer dans l'aventure / Re : Me voilà sur NuTyx
« Dernier message par ouaille_aime_scier le ven. juil. 05 09:30:16 2019 »
Une tiote question hardware : peut-on activer l'écran tactile de mon notebook HP Elitebook ? je n'ai pas trouvé de package pour gérer çà (sur d'autres distributions comme Slackware, Solus et Debian l'écran tactile est automatiquement activé).

Merci d'avance.
92
Un paquet / Re : compilation python conflit
« Dernier message par dania5583 le ven. juil. 05 09:02:02 2019 »
le contenu du log

Checking whether python program exists.../usr/bin/python
Obtaining Python exe path... /usr/bin/python
Obtaining Python lib dir... /usr/lib/python2.7/site-packages                                                              [08:46 x86_64 4.20.17-YaoLinuX root@yaolinux]
Obtaining Python config vars... ok
Altered configuration variables:                                                                                          [08:42 x86_64 4.20.17-YaoLinuX root@yaolinux]
ncurses = False (default True): build with ncurses
magic_hat = False (default True): special Linux PPS hack for Raspberry Pi et al
gpsd_group = uucp (default dialout): privilege revocation group
prefix = /usr (default /usr/local): installation directory prefix
qt_versioned = 5 (default ): version for versioned Qt
sbindir = /usr/bin (default sbin): system binaries directory
WARNING: Python module serial (pyserial) not found.
    ubxtool and zerk will not be installed
WARNING: Python module pycairo not found.
    xgps and xgpsspeed will not be installed
WARNING: Python module pygobject not found.
    xgps and xgpsspeed will not be installed

93
Un paquet / compilation python conflit
« Dernier message par dania5583 le ven. juil. 05 08:30:01 2019 »
Bonjour Thierry
Lorsque je compile des paquets avec des dépendances en python je me trouve confronter à un problème avec la version de python utilisé. En gros je spécifie python  ex python python-cairo python-gobject comme dépendances donc la version 3.7.3 je lance ma compilation et là la version de python pris en compte est la 2.7.16 donc python2 malgré que ce soit python (3.7.3) qui soit demandé ce qui entraîne que les dépendance python-cairo et python-gobject ne sont pas trouvées. Tout rentre dans l'ordre si je met comme dépendances python2 python2-cairo python2-gobject. A moins que dans le code source python2 soit la référence je pense qu'il y a un conflit car dans le répertoire /usr/bin il y a

lrwxrwxrwx 1 root root        7  8 mars  00:06 python -> python2
lrwxrwxrwx 1 root root        9  8 mars  00:06 python2 -> python2.7
-rwxr-xr-x 1 root root    14312  8 mars  00:06 python2.7
-rwxr-xr-x 1 root root     1681  8 mars  00:06 python2.7-config
lrwxrwxrwx 1 root root       16  8 mars  00:06 python2-config -> python2.7-config
lrwxrwxrwx 1 root root        9 27 mars  13:13 python3 -> python3.7
-rwxr-xr-x 2 root root    14312 27 mars  13:14 python3.7
lrwxrwxrwx 1 root root       17 27 mars  13:13 python3.7-config -> python3.7m-config
-rwxr-xr-x 2 root root    14312 27 mars  13:14 python3.7m
-rwxr-xr-x 1 root root     3100 27 mars  13:13 python3.7m-config
lrwxrwxrwx 1 root root       16 27 mars  13:13 python3-config -> python3.7-config
lrwxrwxrwx 1 root root       14  8 mars  00:06 python-config -> python2-config
lrwxrwxrwx 1 root root       10 27 mars  13:13 pyvenv -> pyvenv-3.7
-rwxr-xr-x 1 root root      435 27 mars  13:13 pyvenv-3.7

python a un lien qui pointe vers python2 ce qui expliquerait le fait que ce soit la version python2 qui soit choisi mais je me trompe peut-être

Sinon il doit y avoir un moyen de forcer la compilation en python3 avec une commande sed je crois

Cordialement

Daniel
94
Un paquet / Re : Ajout d'un environnements
« Dernier message par Minzord le jeu. juil. 04 20:33:25 2019 »
En parlent de Pull Request, il y en a deux en attente :)
95
Un paquet / Re : Ajout d'un environnements
« Dernier message par Thierry le jeu. juil. 04 05:10:16 2019 »
Un rapide calcul:

Tu vas sur https://github.com/NuTyX:
 
- Total des commits: près de 2000 depuis la sortie de la 11.0
- Un Pull Request de Minzords accecpté, trois refusé.

ça se passe de commentaires je crois

Thierry
96
Un paquet / Re : Ajout d'un environnements
« Dernier message par jps le mer. juil. 03 21:58:16 2019 »
Seul de chez seul ou sont passé tous les contributeurs meme pas Minzord ?
97
Un paquet / Re : Ajout d'un environnements
« Dernier message par Thierry le mer. juil. 03 20:10:49 2019 »
Non c’est pas dans mes projets. Étant seul maintenant...
98
Un paquet / Re : Ajout d'un environnements
« Dernier message par Paul75 le mer. juil. 03 10:41:24 2019 »
Possible d'intégrer Budgie ?
99
Nouvelles / NuTyX 11.1 disponible
« Dernier message par Thierry le lun. juil. 01 20:57:23 2019 »
NuTyX 11.1 disponible avec cards 2.4.98

J'ai le grand plaisir de vous annoncer la sortie de la nouvelle NuTyX version 11.1.

Cette nouvelle version contient plus de 1000 mise à jour.

Une version 32 bits de NuTyX 11.1 est également disponible.

La base de NuTyX est fournie avec le nouveau kernel LTS 4.19.56 (4.9.183 pour la version 32 bits) et le tout nouveau kernel 5.1.15 (uniquement en 64 bits).

Le compilateur gnu gcc est passé en version 9.1.0

Le serveur graphique xorg-server version 1.20.5, la librairie Mesa 3D en 18.3.6, gtk3 3.24.9 et qt 5.12.4 sont également dans leurs dernières versions

Les interpreteurs python sont en version 3.7.3 et 2.7.16.

L'environnement de bureau MATE est également mis à jour en version 1.22.1, dernière version disponible.

L'environnement de bureau KDE est disponible en Plasma 5.16.2, Framework 5.59.0 et les applications en 19.04.2

Les navigateurs disponibles sont entre autre: firefox 67.0.4 et chromium 74.0.3729.169 (compilé par l'équipe de ArchLinux et uniquement en 64 bits)

De nombreuses applications on été mise à jour également comme thunderbird 60.7.2, Scribus 1.5.5, libreoffice 6.2.4.2, gimp 2.10.12, etc.

4 nouvelles ISOs sont disponible.

    en 64 bits:

    Une ISO NuTyX de base de 384 Moctets en version "rolling".

    Une ISO de 5.3 Goctets est une NuTyX de base version "fixed" qui contient un dépot complet des paquets binaires de la NuTyX 11.1. Avec cette ISO, vous pouvez installer une NuTyX 11.1 complète sans avoir recours à une connection internet. Pour installer des paquets depuis cette ISO, une fois votre système de base installé sur votre disque dur, il faut monter la clé USB sur le dossier /mnt.

    Supposons que votre clé est trouvé sous /dev/sdc1, utilisez la commande:

    sudo mount /dev/sdc1 /mnt

    Adaptez en conséquence.

    Une ISO NuTyX avec l'environnement MATE de 1,7 Goctets en version "rolling".
    en 32 bits:

    Une ISO NuTyX de base de 310 Moctets en version "rolling".

Les ISOs sont disponibles sur la page de téléchargement.

CARDS

CARDS gère désormais les paquets obsètes. Un paquet est obsolète lorqu'il n'est plus disponible sur le serveur distant. Un tel paquet est supprimé automatiquement.

Mise à jour

La NuTyX 11.1 est une mise à jour mineure, une mise à jour est donc possible.

Il est impératif de mettre à jour le paquet cards en premier.

Veuillez utilisez ces quelques commandes pour effectuer une mise à jour sans risque:

check
On met donc cards à jour:

up cards
Ensuite on peut terminer la mise à jour:

sudo cards upgrade

Pages: 1 ... 8 9 [10]